Uploaded image for project: 'WiredTiger'
  1. WiredTiger
  2. WT-3008

Run wtperf stress testing against all maintained branches

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: WT2.9.0, 3.2.11, 3.4.0-rc3, 3.0.16
    • Labels:
      None
    • # Replies:
      7
    • Last comment by Customer:
      true
    • Sprint:
      Storage 2016-11-21

      Description

      1. Move wtperf configs for correctness stress jobs into a bench/wtperf/stress directory.

      2. Change the wiredtiger-test-wtperf Jenkins job to iterate through all configs in that directory rather than hard-coding which ones to run.

      3. Backport the stress configs to mongodb-3.0.

      4. Delete the wiredtiger-test-wtperf-mongodb-* jobs.

        Activity

        xgen-internal-githook Githook User added a comment -

        Author:

        {u'username': u'daveh86', u'name': u'David Hows', u'email': u'howsdav@gmail.com'}

        Message: WT-3008 Move wtperf stress jobs to new stress runner folder (#3131)
        Branch: develop
        https://github.com/wiredtiger/wiredtiger/commit/346180e79d0a9dd89644f63cfd8754723b6ecf60

        xgen-internal-githook Githook User added a comment -

        Author:

        {u'username': u'daveh86', u'name': u'David Hows', u'email': u'howsdav@gmail.com'}

        Message: WT-3008 Move wtperf stress jobs to new stress runner folder (#3133)
        Branch: mongodb-3.0
        https://github.com/wiredtiger/wiredtiger/commit/06ca8c6eec0aabdb683a801f4a0f18aa708ae7cd

        xgen-internal-githook Githook User added a comment -

        Author:

        {u'username': u'daveh86', u'name': u'David Hows', u'email': u'howsdav@gmail.com'}

        Message: WT-3008 Move wtperf stress jobs to new stress runner folder (#3131)
        Branch: mongodb-3.4
        https://github.com/wiredtiger/wiredtiger/commit/346180e79d0a9dd89644f63cfd8754723b6ecf60

        xgen-internal-githook Githook User added a comment -

        Author:

        {u'username': u'michaelcahill', u'name': u'Michael Cahill', u'email': u'michael.cahill@mongodb.com'}

        Message: Import wiredtiger: 74430da40c96247c0a0d92f011ccfb2b175f1f32 from branch mongodb-3.4

        ref: ef9a7983ea..74430da40c
        for: 3.4.0

        SERVER-26753 Minor speed regression (13%) and 'choppy' performance in 3.4 vs 3.2
        WT-2415 Add option for join cursors to return false positives
        WT-2945 Occasional hang running reconfigure fuzz test
        WT-2947 test suite populate functions need refactoring
        WT-2953 Test format failure - stuck cache with 1/42MB dirty
        WT-2961 Add a version drop-down to the web version of the docs
        WT-2964 WTPERF parallel-pop-btree hung in populate phase
        WT-2968 backup cursor opens every file
        WT-2971 Add documentation for raw compression to the WT docs
        WT-2975 Reduce the memory allocated for statistics
        WT-2991 Coverity issue 1365198
        WT-2998 Add error messages to error returns that might be confusing.
        WT-2999 Memory leak in join WT_CURSOR with custom extractor
        WT-3001 WT_EXTENSION_API references are named inconsistently.
        WT-3003 log generation should not auto generate the record and op types
        WT-3005 Add top-level .gitignore file.
        WT-3007 Remove duplicated word in comment
        WT-3008 Run wtperf stress testing against all maintained branches
        WT-3009 Test format hung/aborted with small cache (sub 10mB)
        Branch: master
        https://github.com/mongodb/mongo/commit/0f0db45770f45eab89bd7c2530a259f5ed5b6334

        xgen-internal-githook Githook User added a comment -

        Author:

        {u'username': u'daveh86', u'name': u'David Hows', u'email': u'howsdav@gmail.com'}

        Message: WT-3008 Move wtperf stress jobs to new stress runner folder (#3131)
        Branch: mongodb-3.2
        https://github.com/wiredtiger/wiredtiger/commit/346180e79d0a9dd89644f63cfd8754723b6ecf60

        xgen-internal-githook Githook User added a comment -

        Author:

        {u'name': u'Ramon Fernandez', u'email': u'ramon@mongodb.com'}

        Message: Import wiredtiger: 2e2d5fe23badac038944bdc6639eb62d77136f1a from branch mongodb-3.2

        ref: b11ed312ce..2e2d5fe23b
        for: 3.2.11

        SERVER-26753 Minor speed regression (13%) and 'choppy' performance in 3.4 vs 3.2
        WT-2415 Add option for join cursors to return false positives from a Bloom filter
        WT-2945 Occasional hang running reconfigure fuzz test
        WT-2947 test suite populate functions need refactoring
        WT-2953 Test format failure - stuck cache with 1/42MB dirty
        WT-2961 Add a version drop-down to the web version of the docs
        WT-2964 WTPERF parallel-pop-btree hung in populate phase
        WT-2968 backup cursor opens every file
        WT-2971 Add documentation for raw-compression to the tune_compression page in WT docs
        WT-2975 Reduce the memory allocated for statistics
        WT-2991 Coverity issue 1365198
        WT-2998 Add error messages to error returns that might be confusing.
        WT-2999 Memory leak in join WT_CURSOR with custom extractor
        WT-3001 WT_EXTENSION_API references are named inconsistently.
        WT-3003 log generation should not auto generate the record and op types
        WT-3005 Add top-level .gitignore file.
        WT-3007 Remove duplicated word in comment
        WT-3008 Run wtperf stress testing against all maintained branches
        WT-3009 Test format hung/aborted with small cache (sub 10mB)
        Branch: v3.2
        https://github.com/mongodb/mongo/commit/7c626977cf052314d09648d1061e07c44e964264

        xgen-internal-githook Githook User added a comment -

        Author:

        {u'username': u'agorrod', u'name': u'Alex Gorrod', u'email': u'alexander.gorrod@mongodb.com'}

        Message: Import wiredtiger: d687cc19830b5b479d7474724ed609c416bfb1d2 from branch mongodb-3.0

        ref: b1aab8db7d..d687cc1983
        for: 3.0.16

        WT-2321 Fix a race between eviction and worker threads on the eviction queue
        WT-3000 Missing log records in recovery when crashing after a log file switch
        WT-3008 Run wtperf stress testing against all maintained branches
        WT-3010 shared-cache-stress can hang on mongodb-3.0 branch
        WT-3038 WiredTigers mongodb-3.0 branch crashes and hangs when run against test format
        WT-3049 Backport test/format to mongodb-3.0 branch
        WT-3158 Fix structure layout on Windows.
        WT-3277 [v3.0] Eviction of pages belonging to tables that have been force dropped
        WT-3286 [v3.0] Improve search if an index hint is wrong
        Branch: v3.0
        https://github.com/mongodb/mongo/commit/0513806e66fca4715c20ae5ea64e172a2bf1ee74


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since reply:
              3 days ago
              Date of 1st Reply:

                Agile