Uploaded image for project: 'WiredTiger'
  1. WiredTiger
  2. WT-3082

Python test suite: shorten default run to avoid pull request timeouts.

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: WT2.9.1, 3.5.2, 3.4.3
    • Labels:
      None
    • # Replies:
      10
    • Last comment by Customer:
      true

      Description

      There's a few longer running tests that could be put into the --long category, some easy pickings to shorten the normal test cycle.

        Activity

        donald.anderson Donald Anderson added a comment -

        Thanks, David Hows, that's a bigger change in coverage that I expected. We could push back some of the pruning in the txn07 case, I suppose config03 is affecting the metadata coverage? We do get the better coverage whenever the full test runs (what is that, once a week?) What do you think is a good balance?

        david.hows David Hows added a comment -

        I think the real question is when we care about that difference coverage.

        My feeling is that making the coverage suite run in long mode is probably the best way forward. The idea in limiting the case (as I understand it) was because the subset of cases we would run would provide enough surety that we hadn't broken something major. If that is the case then the long runs should be enough.

        xgen-internal-githook Githook User added a comment -

        Author:

        {u'username': u'daveh86', u'name': u'David Hows', u'email': u'howsdav@gmail.com'}

        Message: Import wiredtiger: 48a3cbc17fa902528217287fd075c87efb44aebc from branch mongodb-3.6

        ref: 8d23249433..48a3cbc17f
        for: 3.5.2

        SERVER-16796 Increase logging activity for journal recovery operations
        WT-2 What does metadata look like?
        WT-2402 Misaligned structure accesses lead to undefined behavior
        WT-2771 Add a statistic to track per-btree dirty cache usage
        WT-2833 improvement: add projections to wt dump utility
        WT-2898 Improve performance of eviction-heavy workloads by dynamically controlling the number of eviction threads
        WT-2994 Create documentation describing page sizes and relationships
        WT-3080 Python test suite: add timestamp or elapsed time for tests
        WT-3082 Python test suite: shorten default run to avoid pull request timeouts.
        WT-3083 Fix a bug in wtperf config dump
        WT-3086 Add transaction state information to cache stuck diagnostic information
        WT-3091 Add stats to test_perf0001
        WT-3092 Quiet a warning from autogen.sh
        WT-3093 Padding the WT_RWLOCK structure grew the WT_PAGE structure.
        WT-3099 lint: static function declarations, non-text characters in documentation
        WT-3100 test bug: format is weighted to delete, insert, then write operations.
        WT-3104 Fix wtperf configs for eviction tests
        WT-3105 Fix a deadlock caused by allocating eviction thread sessions dynamically
        WT-3106 Add truncate support to command line wt utility
        WT-3108 Also dump disk page size as part of metadata information
        WT-3109 wording fix in transaction doc
        WT-3110 Add more test cases for the WT command line utility
        WT-3112 Handle list lock statistic not incremented in eviction server
        WT-3114 Avoid archiving log files immediately after recovery
        WT-3116 Python style testing in s_all may not execute correctly
        WT-3118 Protect random-abort test against unexpectedly slow child start
        WT-3121 In test suite create standard way to load extensions
        WT-3127 bug: CPU yield calls don't necessarily imply memory barriers
        WT-3134 Coverity scan reports 1368529 and 1368528
        Branch: master
        https://github.com/mongodb/mongo/commit/c91b93d2786342505fd9e151c8aa6b68ee03a1fb

        xgen-internal-githook Githook User added a comment -

        Author:

        {u'username': u'ddanderson', u'name': u'Don Anderson', u'email': u'dda@mongodb.com'}

        Message: WT-3082 Python test suite: shorten default run to avoid timeouts. (#3206)

        Tests that have lots of scenarios will have the number of scenarios pruned in the default case. Running with --long restores the previous larger number of scenarios.
        Branch: mongodb-3.4
        https://github.com/wiredtiger/wiredtiger/commit/c0bae91eff62d1545f5c38e8adf83926607e736e

        xgen-internal-githook Githook User added a comment -

        Author:

        {u'username': u'agorrod', u'name': u'Alex Gorrod', u'email': u'alexander.gorrod@mongodb.com'}

        Message: Import wiredtiger: d6659de8d742b9562d08c1ba5138be881f8e24fa from branch mongodb-3.4

        ref: 8d23249433..d6659de8d7
        for: 3.4.3

        SERVER-16796 Increase logging activity for journal recovery operations
        WT-2402 Misaligned structure accesses lead to undefined behavior
        WT-2771 Add a statistic to track per-btree dirty cache usage
        WT-2790 Fix a text case false positive in test_sweep01
        WT-2833 improvement: add projections to wt dump utility
        WT-2898 Improve performance of eviction-heavy workloads by dynamically controlling the number of eviction threads
        WT-2909 Create automatable test verifying checkpoint integrity after errors
        WT-2994 Create documentation describing page sizes and relationships
        WT-3080 Python test suite: add timestamp or elapsed time for tests
        WT-3082 Python test suite: shorten default run to avoid pull request timeouts.
        WT-3083 Fix a bug in wtperf config dump
        WT-3086 Add transaction state information to cache stuck diagnostic information
        WT-3088 bug: Don't evict a page with refs visible to readers after a split
        WT-3091 Add stats to test_perf0001
        WT-3092 Quiet a warning from autogen.sh
        WT-3093 Padding the WT_RWLOCK structure grew the WT_PAGE structure.
        WT-3097 Race on reconfigure or shutdown can lead to waiting for statistics log server
        WT-3099 lint: static function declarations, non-text characters in documentation
        WT-3100 test bug: format is weighted to delete, insert, then write operations.
        WT-3104 Fix wtperf configs for eviction tests
        WT-3105 Fix a deadlock caused by allocating eviction thread sessions dynamically
        WT-3106 Add truncate support to command line wt utility
        WT-3108 Also dump disk page size as part of metadata information
        WT-3109 wording fix in transaction doc
        WT-3110 Add more test cases for the WT command line utility
        WT-3111 util_create() doesnt free memory assigned to "uri"
        WT-3112 Handle list lock statistic not incremented in eviction server
        WT-3113 Add a verbose mode to dump the cache when eviction is stuck
        WT-3114 Avoid archiving log files immediately after recovery
        WT-3115 Change the dhandle lock to a read/write lock
        WT-3116 Python style testing in s_all may not execute correctly
        WT-3118 Protect random-abort test against unexpectedly slow child start
        WT-3120 Fix ordering problem in connection_close for filesystem loaded in an extension
        WT-3121 In test suite create standard way to load extensions
        WT-3126 Fix a bug in dist/s_all script
        WT-3127 bug: CPU yield calls don't necessarily imply memory barriers
        WT-3128 Fix a bug where wt printlog returns operation-not-supported if it doesn't find any log files
        WT-3130 Proposal to change initialization of custom filesystem
        WT-3134 Coverity scan reports 1368529 and 1368528
        WT-3135 search_near() for index with custom collator
        WT-3137 Hang in _log_slot_join/_log_slot_switch_internal
        WT-3139 Enhance wtperf to support periodic table scans
        WT-3143 Fix Coverity static analysis complaint in test program
        WT-3144 bug fix: random cursor returns not-found when descending to an empty page
        WT-3148 Improve eviction efficiency with many small trees
        WT-3149 Change eviction to start new walks from a random place in the tree
        WT-3150 Reduce impact of checkpoints on eviction server
        WT-3152 Convert table lock from a spinlock to a read write lock
        WT-3156 Assertion in log_write fires after write failure
        WT-3157 checkpoint/transaction integrity issue when writes fail.
        WT-3159 Incorrect key for index containing multiple variable sized entries
        WT-3161 checkpoint hang after write failure injection.
        WT-3164 Ensure all relevant btree fields are reset on checkpoint error
        WT-3170 Clear the eviction walk point while populating from a tree
        WT-3173 Add runtime detection for s390x CRC32 hardware support
        WT-3174 Coverity/lint cleanup
        WT-3175 New hang in internal page split
        WT-3179 test bug: clang sanitizer failure in fail_fs
        WT-3180 fault injection tests should only run as "long" tests and should not create core files
        WT-3184 Problem duplicating index cursor with custom collator
        WT-3186 Fix error path and panic detection in logging loops
        WT-3187 Hang on shutdown with a busy cache pool
        WT-3188 Fix error handling in logging where fatal errors could lead to a hang
        WT-3189 Fix a segfault in the eviction server random positioning
        Branch: v3.4
        https://github.com/mongodb/mongo/commit/086c21e2b4c87952273fde78ab8fb18f18e8fdc6


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since reply:
              3 weeks, 3 days ago
              Date of 1st Reply: