Uploaded image for project: 'WiredTiger'
  1. WiredTiger
  2. WT-3602

compatible=(release=2.9) is insufficient for downgrading to 2.9

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.6.0-rc0, WT3.0.0
    • Component/s: None
    • Labels:
      None
    • Sprint:
      Storage 2017-10-02

      Description

      I believe a 3.0 WiredTiger will set its major/minor to 3.0 even if compatible=(release=2.9) is passed in on the first wiredtiger_open call. This prevents WiredTiger 2.9 from opening the database, not because the data format is incompatible, but because of the version that's set.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                sue.loverso Susan LoVerso
                Reporter:
                daniel.gottlieb Daniel Gottlieb
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: