Uploaded image for project: 'WiredTiger'
  1. WiredTiger
  2. WT-3780

Improve error messages on invalid WT_CURSOR::modify usage

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed
    • Minor - P4
    • Resolution: Fixed
    • None
    • 3.6.3, 3.7.1, WT3.1.0
    • None
    • None
    • Storage 2017-12-18

    Description

      Currently when calling WT_CURSOR::modify for a value_format other than u results in a generic ENOTSUP error message being returned:

      [1512060322:445961][9916:0x801216000]: Unsupported cursor operation: Operation not supported
      

      It would be better if a more specific error message was generated describing what the user is doing wrong.

      Attachments

        Activity

          People

            keith.bostic@mongodb.com Keith Bostic (Inactive)
            alexander.gorrod@mongodb.com Alexander Gorrod
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: