Uploaded image for project: 'WiredTiger'
  1. WiredTiger
  2. WT-4833

Drop support for Python2

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: WT3.2.2, 4.4.2, 4.9.0
    • Component/s: None
    • Labels:
      None

      Description

      Brian Lane raised this question in WT-4815, I thought it deserved more visibility.

      I think people in the storage engines group are the primary users of the Python API.  For us, removing python2 support would remove an extra step for anyone making any substantial test changes.  I don't see any downside (for us) to remove support.

      I'm aware of a single user outside MongoDB that occasionally submits Python issues, and they are pushing for Python3.  It's possible there are other (silent) Python2 users.

        Attachments

          Activity

            People

            Assignee:
            donald.anderson Donald Anderson
            Reporter:
            donald.anderson Donald Anderson
            Votes:
            1 Vote for this issue
            Watchers:
            6 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: