Uploaded image for project: 'WiredTiger'
  1. WiredTiger
  2. WT-5196

Data mismatch failures with test/checkpoint after enabling LAS sweep

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: WT3.2.2, 4.3.2
    • Component/s: None
    • Labels:
      None
    • Story Points:
      8
    • Sprint:
      Storage Engines 2019-11-04, Storage Engines 2019-11-18
    • Backport Requested:
      v4.0

      Description

      The change in WT-5150 is enabling the LAS sweep to clean the obsolete records as that is required for the relevant_history project, but it re-introduced a data inconsistency bug. When running 10 parallel test/checkpoint processes with the configuration from WT-4750.

      The fix in WT-5150 is no reason for the failure, but it was hiding the data mismatch bug. Earlier there is no LAS sweep that was happening, so the issue does not occur.

      The data mismatch bug needs to find and correct it.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                haribabu.kommi Haribabu Kommi
                Reporter:
                haribabu.kommi Haribabu Kommi
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: