Uploaded image for project: 'WiredTiger'
  1. WiredTiger
  2. WT-7437

Upgrade documentation to doxygen 1.8.17

    XMLWordPrintable

Details

    • v3.6

    Description

      Currently wiredtiger runs an outdated doxygen version 1.8.13. Wiredtiger has had a history of problems with doxygen and it's incompatible versioning problems. Having a doxygen outdated version also brings nuisances to the server build team, as we have to constantly tell them to downgrade their doxygen versions on new distros.
      This ticket aims to upgrade the doxygen version to be compatible with all the evergreen build variants:

      1. Investigate all evergreen build variants and their doxygen versions
      2. Use a doxygen version compatible with all evergreen builds
      3. Fix the errors produced by the a newer doxygen version

      Update existing build variants if possible to 1.8.17.

      Attachments

        Issue Links

          Activity

            People

              keith.bostic@mongodb.com Keith Bostic (Inactive)
              jie.chen@mongodb.com Jie Chen
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: