Uploaded image for project: 'WiredTiger'
  1. WiredTiger
  2. WT-8586

Data validation stress tests fail when logging is enabled

    XMLWordPrintable

Details

    Description

      Summary

      While working on WT-8370 to expand the amount of non-timestamped testing, Hari observed a test failure. Disabling logging fixed it, but this seems to be hiding the real issue.

      Motivation

      Does this affect any team outside of WT?

      No

      How likely is it that this use case or problem will occur?

      If logging is enabled, it's broken 100% of the time.

      If the problem does occur, what are the consequences and how severe are they?

      It looks to be an issue with the test setup rather than a WT bug, so this isn't a huge problem.

      Is this issue urgent?

      No

      Acceptance Criteria (Definition of Done)

      (1) Figure out why enabling logging causes the issue, and (2) either fix it or have a good reason not to fix it.

      Testing

      Remove the `log=(enabled=false)` section in `test/checkpoint/workers.c` and run the data validation stress test (`data-validation-stress-test-checkpoint` and friends).

      Documentation update

      N/A

      Attachments

        Issue Links

          Activity

            People

              keith.bostic@mongodb.com Keith Bostic (Inactive)
              will.korteland@mongodb.com Will Korteland
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: