Uploaded image for project: 'Compass '
  1. Compass
  2. COMPASS-2846

Validate TLS 1.2 Support with MongoDB 4.0

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 1.14.0, 1.15.0
    • Component/s: Compass
    • Labels:
      None
    • # Replies:
      0
    • Last comment by Customer:
      true
    • Story Points:
      2
    • Epic Link:
    • Sprint:
      Sprint Xzibit

      Description

      We need to verify that the latest version of Compass can connect to a MongoDB 3.7.9/4.0.0 instance with --requireSSL enabled [--sslDisabledProtocols=TLS1_0] (1.0 is disabled by default).

      This is enough to mark Compass as done with regards to the company/product wide Safe TLS initiative driven by the PCI-DSS deadline of June 30, 2018 where TLS 1.0 must be disabled by default everywhere. 

        Attachments

        1. Screen Shot 2018-06-08 at 2.34.53 PM.png
          Screen Shot 2018-06-08 at 2.34.53 PM.png
          493 kB
        2. Screen Shot 2018-06-08 at 2.35.24 PM.png
          Screen Shot 2018-06-08 at 2.35.24 PM.png
          480 kB
        3. server.log
          5 kB

          Activity

            People

            • Assignee:
              durran.jordan Durran Jordan
              Reporter:
              matt.lord Matt Lord
              Participants:
              Last commenter:
              Jessica Sigafoos
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Due:
                Created:
                Updated:
                Resolved:
                Days since reply:
                1 year, 47 weeks, 2 days ago
                Date of 1st Reply: