Uploaded image for project: 'C++ Driver'
  1. C++ Driver
  2. CXX-1306

Require at least C++17

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Open
    • Priority: Major - P3
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Build, Implementation
    • Labels:
      None
    • Backwards Compatibility:
      Major Change

      Description

      As part of an overhaul of bsoncxx, we should rely on C+17's std::variant instead of typed unions. With a bump to C17, we can drop polyfills and rely only on the C+17 standard library.

      We'll need to assess C++17 support by compilers for major platforms and use this as one of the main features for a 4.0 (or 5.0) release.

      When scheduled, this should be converted to an Epic ticket and individual tickets created for the work required to complete the transition to C++17.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              david.golden David Golden
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated: