Uploaded image for project: 'PHP Driver: Extension'
  1. PHP Driver: Extension
  2. PHPC-996

Remove support for PHP 5.4

    XMLWordPrintable

Details

    • Task
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • None
    • 1.3.0-RC1, 1.3.0
    • None
    • None

    Description

      PHP 5.4 has been unsupported for nearly two years (see: EOL and Supported Versions). PHPLIB 1.2.0 will likely require PHP 5.5+ for generators, so this would be a good time to bump the requirement in the extension as well.

      This task would entail:

      • Bump the version requirement in package.xml
      • Remove compatibility code for cursor iteration (see: Cursor.c and phongo_compat.h)
      • Remove pre-5.5 SKIPIF checks in test files

      Attachments

        Issue Links

          Activity

            People

              jmikola@mongodb.com Jeremy Mikola
              jmikola@mongodb.com Jeremy Mikola
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: