Uploaded image for project: 'PHP Driver: Extension'
  1. PHP Driver: Extension
  2. PHPC-1377

Remove support for PHP 5.5

    XMLWordPrintable

Details

    • Task
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • None
    • 1.6.0alpha3, 1.6.0
    • None
    • None

    Description

      PHP 5.5 has been unsupported for more than two years (see: EOL and Supported Versions). The most recent PHP Version Stats (2018.1), which are derived from Composer usage, also report only 3.5% overall usage for PHP 5.5.

      This task would entail:

      • Bump the version requirement in package.xml
      • Remove any compatibility code around macro definitions
      • Remove any pre-5.6 SKIPIF checks in test files
      • Reach out to remi regarding any downstream changes for Fedora packaging

      Attachments

        Issue Links

          Activity

            People

              andreas.braun@mongodb.com Andreas Braun
              jmikola@mongodb.com Jeremy Mikola
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: