Uploaded image for project: 'Python Driver'
  1. Python Driver
  2. PYTHON-2102

Test MongoDB 4.4 on Windows with Python 2.7, 3.4, 3.5, and 3.6

    XMLWordPrintableJSON

Details

    • Task
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • None
    • 3.11
    • None
    • None

    Description

      We already moving our testing of MongoDB 4.3 to windows-64-vs2017 in PYTHON-2070, however that change removes test coverage of Python 2.7, 3.4, 3.5, and 3.6 C-extensions against MongoDB 4.3. I opened the following build tickets:

      • BUILD-9930 Add Microsoft Visual C++ Compiler for Python 2.7 to windows-64-vs2017-* variants
      • Required for Python 2.7
      • BUILD-9934 Add Microsoft Visual C++ Compiler 10.0 to windows-64-vs2017-* variants 
        • Required for Python 3.4
      • BUILD-9935 Upgrade setuptools in the Windows Python toolchain (for windows-64-vs2017)
        • Required for Python 3.5 and 3.6. The currently installed setuptools version is too old to support the VS 2017 compiler.

      Attachments

        Issue Links

          Activity

            People

              shane.harvey@mongodb.com Shane Harvey
              shane.harvey@mongodb.com Shane Harvey
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: