Uploaded image for project: 'Ruby Driver'
  1. Ruby Driver
  2. RUBY-1634

Require bundler < 2 in CI

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed
    • Critical - P2
    • Resolution: Fixed
    • None
    • 2.7.0.rc0, bson-4.4.1
    • Tests
    • 1
    • Fully Compatible

    Description

      Looks like bundler 2 has just been released, which requires rubygems 3 which we don't have anywhere in Evergreen.

      https://bundler.io/blog/2019/01/03/announcing-bundler-2.html

      The CI is failing thusly:

      [2019/01/03 13:37:22.159] + gem install bundler
      [2019/01/03 13:37:22.159] ERROR: Error installing bundler:
      [2019/01/03 13:37:22.159] The last version of bundler (>= 0) to support your Ruby & RubyGems was 1.17.3. Try installing it with `gem install bundler -v 1.17.3`
      [2019/01/03 13:37:22.159] bundler requires RubyGems version >= 3.0.0. The current RubyGems version is 2.7.6. Try 'gem update --system' to update RubyGems itself.
      [2019/01/03 13:37:22.163] ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-linux]

      For the time being we should probably just request bundler < 2.

      Our travis config updates rubygems prior to installing bundler, and should therefore get rubygems 3 and bundler 2.

      Attachments

        Issue Links

          Activity

            People

              oleg.pudeyev@mongodb.com Oleg Pudeyev
              oleg.pudeyev@mongodb.com Oleg Pudeyev
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: