Uploaded image for project: 'Ruby Driver'
  1. Ruby Driver
  2. RUBY-3090

SDAM should prioritize electionId over setVersion only on >=6.0 servers

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Unknown
    • Resolution: Fixed
    • None
    • 2.19.0
    • SDAM
    • None
    • Hide

      DRIVERS-2412:

      • Sync spec changes in 37c32c
      • Confirm tests fail with current updateRSFromPrimary implementation
      • Summary of updateRSFromPrimary changes:
        • If maxWireVersion 17 or greater
        • Prioritize electionId before setVersion
        • Handle nullish values for both setVersion and electionId
        • always set maxElectionId and maxSetVersion together (they are a tuple value)
      • Confirm tests pass with changes

      Join #drivers-2412-sdam-should-prioritize-electionid-over-setversion on slack for any questions

      Show
      DRIVERS-2412 : Sync spec changes in 37c32c Confirm tests fail with current updateRSFromPrimary implementation Summary of updateRSFromPrimary changes: If maxWireVersion 17 or greater Prioritize electionId before setVersion Handle nullish values for both setVersion and electionId always set maxElectionId and maxSetVersion together (they are a tuple value) Confirm tests pass with changes Join #drivers-2412-sdam-should-prioritize-electionid-over-setversion on slack for any questions

    Description

      This ticket was split from DRIVERS-2412, please see that ticket for a detailed description.

      Attachments

        Issue Links

          Activity

            People

              dmitry.rybakov@mongodb.com Dmitry Rybakov
              dbeng-pm-bot PM Bot
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: