The current okForStorage misses some edge cases. For the new update framework, we would like to fix these.
Marking QA needed since an adversary trying to produce bad field names would be helpful.
Apply okForStorage to object replacement updates in modifier_object_replace
Possible to create docs with dotted field names
Allow sharding metadata collections to bypass okForStorage checks