Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-12753

Specify cyrus-sasl and net-snmp-libs versions in enterprise rpm dependencies

    XMLWordPrintable

Details

    • Task
    • Status: Closed
    • Minor - P4
    • Resolution: Fixed
    • 2.4.9, 2.5.5
    • 2.6.0-rc2
    • Packaging
    • None
    • Fully Compatible

    Description

      It's possible to install newer versions of snmp packages that don't work with mongodb binaries.

      To reproduce in CentOS 6.4:

      wget  http://download.opensuse.org/repositories/home:/ericgearhart:/net-snmp-57/CentOS_CentOS-6/x86_64/net-snmp-libs-5.7.1-31.3.x86_64.rpm http://download.opensuse.org/repositories/home:/ericgearhart:/net-snmp-57/CentOS_CentOS-6/x86_64/net-snmp-devel-5.7.1-31.3.x86_64.rpm  http://download.opensuse.org/repositories/home:/ericgearhart:/net-snmp-57/CentOS_CentOS-6/x86_64/net-snmp-5.7.1-31.3.x86_64.rpm http://download.opensuse.org/repositories/home:/ericgearhart:/net-snmp-57/CentOS_CentOS-6/x86_64/net-snmp-utils-5.7.1-31.3.x86_64.rpm
      yum localinstall net-snmp-*
      yum install mongodb-enterprise-unstable-server
      mongod

      The error:

      mongod: error while loading shared libraries: libnetsnmpagent.so.20: cannot open shared object file: No such file or directory

      Attachments

        Issue Links

          Activity

            People

              ernie.hershey@mongodb.com Ernie Hershey
              ernie.hershey@mongodb.com Ernie Hershey
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: