-
Type:
Task
-
Resolution: Unresolved
-
Priority:
Major - P3
-
None
-
Affects Version/s: None
-
Component/s: Upgrade/Downgrade
-
None
-
Catalog and Routing
-
🟩 Routing and Topology
-
None
-
None
-
None
-
None
-
None
-
None
Description
setFCV fails during the FCV 8.x ↔ 9.0 transition if there are index builds in progress, since it's incompatible with various upgrade requirements of FCV 9.0-gated features (SERVER-122468).
Now that 9.0 is last LTS, we can allow setFCV + index builds again to provide a more frictionless upgrade/downgrade experience for users.
Â
Details
This requires removing or disabling the following two mechanisms:
- IndexBuildFCVStep (feasibility check)
- Registering index builds as "long running operations with a version context" which then causes setFCV to fail on the draining step.
- depends on
-
SERVER-100328 Cleanup deprecated entries in kAllowedFieldNames after 9.0
-
- Backlog
-
- is related to
-
SERVER-122468 Stop setFCV at feasibility phase if there are index builds in progress
-
- Closed
-