Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-14089

Remove support for v2.4 schema users

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.7.2
    • Component/s: Security
    • Labels:
      None

      Description

      v2.4-style users are deprecated in v2.6, and add a lot of complicated mechanics to the auth code. Worse, they require that the ability to read from collections be available in a lot of places where it wouldn't otherwise be needed.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: