Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-14090

Gracefully fail at startup of mongod and mongos if authSchemaVersion < authSchemaVersion26Final

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.7.7
    • Component/s: Security
    • Labels:
      None

      Description

      As of SERVER-14089 (MongoDB 2.7.2), the auth schema version must be authSchemaVersion26 (3). Mongos and mongod should check early in execution that this is so, and log a message and terminate if it is not.

      This ticket should also include writing a multiVersion test to ensure this behavior.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              amalia.hawkins@10gen.com Amalia Hawkins
              Reporter:
              schwerin Andy Schwerin
              Participants:
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: