Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-15920

Segmentation fault on mongod processes and mongo shell

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical - P2
    • Resolution: Duplicate
    • Affects Version/s: 2.6.5
    • Fix Version/s: None
    • Component/s: Shell, Stability
    • Labels:
    • Environment:
      OS : Gentoo Linux
      Kernel 3.9.9
      GCC : tested on 4.6.4 / 4.7.3-r1 / 4.8.3
      glic : tested on 2.15-r3 and 2.19-r1
      Boost : tested on 1.53.0 and 1.55.0-r2
    • Operating System:
      Linux

      Description

      Since we upgraded from 2.4.10 to 2.6.5, some nodes crash randomly by segmentation fault (mongod.txt). On these nodes, the mongo shell won't start and do a segfault on startup (mongo-shell.txt).
      We have tried to recompile mongodb with different versions of gcc or of the gilbc, which don't solve the problem. Same result when we disable all the compilation options (use-system-yaml, use-system-boost, use-system-pcre...).
      The default compilation options are available in this ebuild : http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-db/mongodb/mongodb-2.6.5.ebuild?view=markup

      Other nodes have the same configuration, and mongo runs perfectly.

        Attachments

        1. mongo_shell_strace.txt
          18 kB
        2. mongo_shell.txt
          1 kB
        3. mongod.txt
          2 kB

          Issue Links

            Activity

              People

              • Votes:
                1 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: