Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-16255

Enforced SCons minimum is insufficiently high to support TextFile

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Trivial - P5
    • Resolution: Fixed
    • None
    • 2.8.0-rc2
    • Build
    • None
    • Fully Compatible
    • ALL
    • Hide

      Attempt to build with SCons older than 1.3.

      Show
      Attempt to build with SCons older than 1.3.

    Description

      In b0d74105634a3a2040743061c53b0e5b4eff919d (where we merged in the WT integration), we became dependent on the SCons 'textfile' tool.

      This tool requires SCons 1.3, minimum, however, our top level SConstruct only requires SCons 1.1.

      We should update the required minimum to reflect reality.

      Attachments

        Issue Links

          Activity

            People

              matt.kangas Matt Kangas
              andrew.morrow@mongodb.com Andrew Morrow
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: