Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-17191

Spurious warning during upgrade of sharded cluster

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.6.8
    • Component/s: Logging, Sharding
    • Labels:
      None
    • Backwards Compatibility:
      Fully Compatible
    • Operating System:
      ALL

      Description

      When upgrading from 2.6 to 2.8, the mongod will spam the config server logs with the following message:
      The "bad serverID set in setShardVersion and none in info: EOO"

      I believe this was introduced in the fix for SERVER-16733 and should be harmless, but need to verify. Message goes away once config servers are upgrade to 3.0.0

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: