Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-17836

Enforce OS minima with configure checks

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed
    • Major - P3
    • Resolution: Won't Fix
    • None
    • None
    • Build
    • Fully Compatible

    Description

      Currently, building the server on a platform that does not meet our required OS minimum will likely result in a compile error (see SERVER-17813).

      We should attempt to verify that the target OS meets our requirements with a configure check and terminate the build with an error message if the configure check fails.

      Much like we have for compiler version enforcement, we should also probably provide an override flag (--disable-minimum-target-os-version-enforcement or something).

      Attachments

        Issue Links

          Activity

            People

              backlog-server-platform DO NOT USE - Backlog - Platform Team
              andrew.morrow@mongodb.com Andrew Morrow
              Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: