Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-17837

Enforce minimum versions of third party libraries when using the system version

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Major - P3
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: Backlog
    • Component/s: Build
    • Labels:

      Description

      We allow users to build the server against the system version of some of the third party libraries instead of using our vendored versions.

      Much like in SERVER-17836, we should enforce that when a system version of the library is selected, that it is a reasonable version.

      What "reasonable" means here may require some elaboration. As always, a flag to override these checks should be provided.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: