Core Server
  1. Core Server
  2. SERVER-2200

"limit nofile 20000" in upstart job breaks things

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major - P3 Major - P3
    • Resolution: Fixed
    • Affects Version/s: 1.6.5
    • Fix Version/s: 1.7.4
    • Component/s: None
    • Labels:
      None
    • Backport:
      No
    • Operating System:
      ALL
    • # Replies:
      7
    • Last comment by Customer:
      true

      Description

      The debian packages now seem to have this line in the upstart job, and lots of people are getting "start: Unknown job: mongodb";

      I think this needs to get rolled back ASAP!

        Issue Links

          Activity

          Timothy Bell
          added a comment - - edited

          I currently have over thirty systems with this issue...... (some 10.10 but mostly 10.4 LTS, All 64 bit)

          I tried removing "limit nofile 20000" and I'm able to run "sudo start mongodb".

          I no longer get the "start: Unknown job: mongodb" message but the process is not running when I run "ps".

          I was able to start my mongo servers manually by running "sudo mongod --dbpath /var/lib/mongodb". But as of right now the upstart script has an issue.

          Show
          Timothy Bell
          added a comment - - edited I currently have over thirty systems with this issue...... (some 10.10 but mostly 10.4 LTS, All 64 bit) I tried removing "limit nofile 20000" and I'm able to run "sudo start mongodb". I no longer get the "start: Unknown job: mongodb" message but the process is not running when I run "ps". I was able to start my mongo servers manually by running "sudo mongod --dbpath /var/lib/mongodb". But as of right now the upstart script has an issue.
          Timothy Bell
          added a comment -

          OK..... workaround (i guess); what work for me anyway.

          sudo apt-get purge mongodb-stable
          sudo apt-get install mongodb-stable
          (remove the lock file if present in /var/lib/mongodb)
          sudo init 6

          Then edit /etc/init/mongodb.conf removing the line "limit nofile 20000"

          sudo vi /etc/init/mongodb.conf
          sudo init 6

          I'm now back up and running..... FYI confirmed fix in a number of systems 10.10 and 10.04 LTS

          Show
          Timothy Bell
          added a comment - OK..... workaround (i guess); what work for me anyway. sudo apt-get purge mongodb-stable sudo apt-get install mongodb-stable (remove the lock file if present in /var/lib/mongodb) sudo init 6 Then edit /etc/init/mongodb.conf removing the line "limit nofile 20000" sudo vi /etc/init/mongodb.conf sudo init 6 I'm now back up and running..... FYI confirmed fix in a number of systems 10.10 and 10.04 LTS
          Serge Matveenko
          added a comment -

          deleting this line and starting mongodb service just works for me

          Show
          Serge Matveenko
          added a comment - deleting this line and starting mongodb service just works for me
          auto
          added a comment -

          Author:

          {u'login': u'kreuter', u'name': u'Richard Kreuter', u'email': u'richard@10gen.com'}

          Message: Fix error in upstart file. SERVER-2200
          https://github.com/mongodb/mongo/commit/96656759e7370cc1bea42d08941c0bb116089f99

          Show
          auto
          added a comment - Author: {u'login': u'kreuter', u'name': u'Richard Kreuter', u'email': u'richard@10gen.com'} Message: Fix error in upstart file. SERVER-2200 https://github.com/mongodb/mongo/commit/96656759e7370cc1bea42d08941c0bb116089f99
          Richard Kreuter
          added a comment -

          I think this is fixed in git head. Pushing new packages now.

          Show
          Richard Kreuter
          added a comment - I think this is fixed in git head. Pushing new packages now.
          Richard Kreuter
          added a comment -

          The fixed upstart file is present in packages with version number 20101210. By inspection on a 10.4 system, 'aptitude install mongodb-stable' installs the new conf file and starts the service successfully.

          Show
          Richard Kreuter
          added a comment - The fixed upstart file is present in packages with version number 20101210. By inspection on a 10.4 system, 'aptitude install mongodb-stable' installs the new conf file and starts the service successfully.
          Serge Matveenko
          added a comment -

          I can confirm for 10.04-amd64 and 10.10-amd64

          Show
          Serge Matveenko
          added a comment - I can confirm for 10.04-amd64 and 10.10-amd64

            People

            • Votes:
              3 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since reply:
                3 years, 19 weeks, 2 days ago
                Date of 1st Reply: