Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-2201

Ubuntu "start: Unknown job: mongodb" error after upgrade

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor - P4
    • Resolution: Duplicate
    • Affects Version/s: 1.6.5
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      Ubuntu 10.04 / MongoDB 1.6.5
    • Operating System:
      ALL

      Description

      Problem:
      Several users are reporting the same issue after upgrade an existing MongoDB install from 1.6.x to 1.6.5

      The start script is failing with "start: Unknown job: mongodb"

      Workaround:

      In "/etc/init/mongodb.conf" comment out, or remove, the "limit nofile 20000" line.

        Issue Links

          Activity

          bitzesty Matthew Ford added a comment -

          duplicate of #2200

          bellts Timothy Bell added a comment -

          I had to purge and reinstall mongo before this workaround would work.

          After the install, remove the "limit nofile 20000" line from "/etc/init/mongodb.conf"

          richard.kreuter Richard Kreuter added a comment -

          I think this is fixed in git head. Pushing new packages now. See SERVER-2200.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: