Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-36455

Pip dependencies are not installable with openssl >= 1.1.0f

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Operating System:
      ALL

      Description

      buildscripts/requirements.txt specifies cryptography==1.7.2. This fails on openssl >= 1.1.0f with this error: https://github.com/pyca/cryptography/issues/3605

      Debian testing presently ships openssl 1.1.0h.

      The comment on top of requirements.txt seems to imply that cryptography is only used for jira integration, and grepping the tree doesn't seem to produce any hints of it being used anywhere.

      Affects 4.0.0 tag as well as master.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: