Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-37588

Python linters version incompatability

    XMLWordPrintable

    Details

    • Backwards Compatibility:
      Fully Compatible
    • Operating System:
      ALL
    • Sprint:
      Service Arch 2018-10-22

      Description

      The work for SERVER-36152 introduced etc/pip/constraints.txt which defines the versions for the various pip components. There are some conflicts with the versions that are defined in the Python linters in buildscripts/linter/:

      • yapf 0.21.0
      • pylint 1.8.3
      • pydocstyle 2.1.1
      • mypy 0.580

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              ben.caimano Benjamin Caimano
              Reporter:
              jonathan.abrahams Jonathan Abrahams
              Participants:
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: