Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-37755

Invalid .plist for mongoc and bson .frameworks

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • None
    • 4.0.4, 4.1.5
    • None
    • None
    • Fully Compatible
    • ALL
    • v4.0
    • Dev Tools 2018-11-05

    Description

      Received this error when trying to submit to the App Store:

      App Store Connect Operation Error
      ERROR ITMS-90530: "Invalid MinimumOSVersion. Apps that only support 64-bit devices must specify a deployment target of 8.0 or later. MinimumOSVersion in 'MongoU.app/Frameworks/bson.framework' is ''."

      App Store Connect Operation Error
      ERROR ITMS-90530: "Invalid MinimumOSVersion. Apps that only support 64-bit devices must specify a deployment target of 8.0 or later. MinimumOSVersion in 'MongoU.app/Frameworks/mongoc.framework' is ''."

      App Store Connect Operation Error
      ERROR ITMS-90360: "Missing Info.plist value. A value for the key 'MinimumOSVersion' in bundle MongoU.app/Frameworks/bson.framework is required."

      App Store Connect Operation Error
      ERROR ITMS-90360: "Missing Info.plist value. A value for the key 'MinimumOSVersion' in bundle MongoU.app/Frameworks/mongoc.framework is required."

      App Store Connect Operation Error
      ERROR ITMS-90060: "This bundle is invalid. The value for key CFBundleShortVersionString '1.13.1-dev' in the Info.plist file must be a period-separated list of at most three non-negative integers."

      App Store Connect Operation Error
      ERROR ITMS-90058: "This bundle is invalid. The value for key CFBundleVersion [1.13.1-dev] in the Info.plist file must be a period-separated list of at most three non-negative integers."

      App Store Connect Operation Error
      ERROR ITMS-90208: "Invalid Bundle. The bundle MongoU.app/Frameworks/bson.framework does not support the minimum OS Version specified in the Info.plist."

      App Store Connect Operation Error
      ERROR ITMS-90208: "Invalid Bundle. The bundle MongoU.app/Frameworks/mongoc.framework does not support the minimum OS Version specified in the Info.plist."

      Attachments

        Activity

          People

            andrew.morrow@mongodb.com Andrew Morrow
            jason.flax@mongodb.com Jason Flax
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: