Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-55525

Show a warning in the legacy shell that it is deprecated

    XMLWordPrintable

Details

    • Fully Compatible
    • v5.0
    • STM 2021-06-14
    • 2

    Description

      mongosh will be released for GA concurrently with the 5.0 server release.  At this time, when someone installs and runs mongo, they should see a deprecation warning that points them to download mongosh instead.

      This is work is part of the New MongoDB Shell GA and Deprecation & EOL strategy for Legacy Shell Initiative and is outlined in the Initiative Plan.

      Attachments

        Issue Links

          Activity

            People

              robert.guo@mongodb.com Robert Guo
              jessica.sigafoos@mongodb.com Jessica Sigafoos
              Votes:
              0 Vote for this issue
              Watchers:
              11 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: