Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-56550

Require Versioned API options for getMore and transaction-continuing commands

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.0.0-rc0
    • Component/s: None
    • Labels:
      None
    • Backwards Compatibility:
      Fully Compatible
    • Sprint:
      Elastic 2021-05-10, Elastic 2021-05-17

      Description

      Once the dust settles onĀ SERVER-55614 (make Versioned API params optional for getMore/txn-continuing commands), make them required. The API params for getMore must be exactly the same as those submitted with the cursor-creating command, and those submitted with a txn-continuing command must exactly match those of the txn-initiating command.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              jesse A. Jesse Jiryu Davis
              Reporter:
              jesse A. Jesse Jiryu Davis
              Participants:
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: