Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-57541

mypy 0.900 breaks lint_pylinters

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • None
    • 4.4.7, 5.0.0-rc1, 5.1.0-rc0
    • None
    • None
    • Fully Compatible
    • ALL
    • v5.0, v4.4, v4.2
    • STM 2021-06-14
    • 0
    • 0

    Description

      0.900 breaks our python linter task. In the longer run we have a ticket to freeze all dependencies, for now we'll just pin mypy.

      Attachments

        Activity

          People

            richard.samuels@mongodb.com Richard Samuels
            richard.samuels@mongodb.com Richard Samuels
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: