Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-62686

Can't build due to pinned dependencies

    XMLWordPrintable

Details

    • Bug
    • Status: Waiting For User Input
    • Major - P3
    • Resolution: Unresolved
    • None
    • None
    • None
    • None
    • ALL

    Description

      I'm working on updating mongodb-devel in MacPorts to 5.2.0 and it fails because of the resolution of SERVER-57312:

      Checking required python packages...
      Requirements list:
          Cheetah3<=3.2.6.post1
          PyYAML<=6.0.0,>=3.0.0
          oauthlib==3.1.1
          packaging<=21.3
          pkce==1.0.3
          psutil<=5.8.0
          pymongo<4.0,>=3.9
          pypiwin32==223; sys_platform == "win32" and python_version > "3"
          pywin32==225; sys_platform == "win32" and python_version > "3"
          regex<=2021.11.10
          requests-oauthlib==1.3.0
          requests<=2.26.0,>=2.0.0
          requirements_parser<=0.3.1
          setuptools
      (Cheetah3 3.2.6.post2 (/opt/local/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages), Requirement.parse('Cheetah3<=3.2.6.post1'))
      

      Reverting b6d30f82753814220e360b82d0b5d87e834b279c allows me to get past that but I don't yet know if the build would be successful because of the new dependency on [pkce which is not yet in MacPorts|https://trac.macports.org/ticket/64459].

      Attachments

        Issue Links

          Activity

            People

              backlog-server-devplatform Backlog - Server Development Platform Team (SDP)
              ryandesign Ryan Schmidt
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated: