Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-9627

Startup Warning error shown when connecting with 2.4 shell to 2.2 mongod with auth

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: 2.4.3
    • Fix Version/s: 2.5.1
    • Component/s: Shell
    • Labels:
    • Environment:
      2.2 MongoD
      2.4 Shell
    • Backwards Compatibility:
      Fully Compatible
    • Operating System:
      ALL

      Description

      If you connect to a 2.2 MongoD instance while not auth'd as an admin using a 2.4 shell you will see the following

      Error while trying to show server startup warnings: need to login

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              scotthernandez Scott Hernandez
              Reporter:
              david.hows David Hows
              Participants:
              Votes:
              7 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: