Uploaded image for project: 'MongoDB Database Tools'
  1. MongoDB Database Tools
  2. TOOLS-2752

TEST: "no users authenticated" on tools connection to DB with no users defined

    XMLWordPrintable

    Details

    • Type: Investigation
    • Status: Closed
    • Priority: Minor - P4
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: No versions
    • Component/s: None
    • Labels:
      None

      Description

      Hi Team!

      Sorry for potential noise. DOCS received an error report (DOCS-13886) as follows:

      I tried to follow mongodb docs and tried to make a dump of the local mongodb database with no authentication enabled. Compass connects just fine with no parameters

      But when I try running

      mongodump
      

      it results in the following error message:

      Failed: error creating intents to dump: error getting database names: (Unauthorized) there are no users authenticated
      

      The problem is: I don't have authentication mode enabled.

      I have been unable to reproduce this in my testing, but Asya Kamsky chimed in and mentioned that explicitly keying in the localhost IP ( 127.0.0.1 ) bypasses this issue, and indeed it did for this user. Bypass:

      mongodump mongodb://127.0.0.1:27017
      

      This makes it seem like we might have stumbled on a bug, but I don't have repro steps for you (unable to repo in all of my attempts).

      The user has provided good diagnostic info in the linked DOCS ticket (in comments and an uploaded log.txt file). I've also attached my (unsuccessful) repro attempts to that ticket as well, testing both 4.4.0 and 4.4.1.

      Hope this is the right thing to do (report potential bug w/o repro steps). If not, feel free to disregard. Thanks much for your time!

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              evgeni.dobranov Evgeni Dobranov
              Reporter:
              andrew.feierabend Andrew Feierabend (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: