Uploaded image for project: 'WiredTiger'
  1. WiredTiger
  2. WT-2265

Wiredtiger related change in ppc64le specific code block in gcc.h

    • Type: Icon: Task Task
    • Resolution: Done
    • Priority: Icon: Major - P3 Major - P3
    • WT2.8.0
    • Affects Version/s: None
    • Component/s: None
    • Environment:
      OS: Red Hat Enterprise Linux
      Arch: PPC64LE
    • Platform D (12/11/15)

      This patch is in continuation of WT-1942. Patch merged under WT-1942 was meant to enable wiredtiger while building MongoDB server 3.2 on ppc64le architecture. However, that patch had one issue due to which on ppc64le, we get following error while building -
      gcc -o build/opt/third_party/wiredtiger/src/block/block_ckpt.o -c -std=c99 -fno-omit-frame-pointer -fPIC -fno-strict-aliasing -ggdb -pthread -Wall -Wsign-compare -Wno-unknown-pragmas -Winvalid-pch -Werror -O2 -Wno-unused-local-typedefs -Wno-unused-function -Wno-deprecated-declarations -Wno-unused-but-set-variable -Wno-missing-braces -fno-builtin-memcmp -DPCRE_STATIC -DNDEBUG -DBOOST_THREAD_VERSION=4 -DBOOST_THREAD_DONT_PROVIDE_VARIADIC_THREAD -DBOOST_SYSTEM_NO_DEPRECATED -DBOOST_THREAD_DONT_PROVIDE_INTERRUPTIONS -DBOOST_THREAD_HAS_NO_EINTR_BUG -DHAVE_VERBOSE -DHAVE_FALLOCATE -DHAVE_SYNC_FILE_RANGE -D_GNU_SOURCE -DHAVE_BUILTIN_EXTENSION_ZLIB -DHAVE_BUILTIN_EXTENSION_SNAPPY -Isrc/third_party/snappy-1.1.2 -Isrc/third_party/zlib-1.2.8 -Ibuild/opt/third_party/wiredtiger -Isrc/third_party/wiredtiger -Ibuild/opt/third_party/wiredtiger/src/include -Isrc/third_party/wiredtiger/src/include -Ibuild/opt/third_party/wiredtiger/build_linux -Isrc/third_party/wiredtiger/build_linux src/third_party/wiredtiger/src/block/block_ckpt.c
      In file included from src/third_party/wiredtiger/src/include/wt_internal.h:300:0,
      from src/third_party/wiredtiger/src/async/async_api.c:9:
      src/third_party/wiredtiger/src/include/gcc.h:182:10: error: expected '(' before 'volatile'
      asm volatile ("sync" ::: "memory"); \
      ^
      src/third_party/wiredtiger/src/include/gcc.h:183:1: error: expected identifier or '(' before '}' token
      } while (0)
      ^
      src/third_party/wiredtiger/src/include/gcc.h:183:3: error: expected identifier or '(' before 'while'
      } while (0)
      ^
      Attached patch contains the fix for above issue. Kindly consider it for merging.

            Assignee:
            mark.benvenuto@mongodb.com Mark Benvenuto
            Reporter:
            nishidha Nishidha
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Created:
              Updated:
              Resolved:

                Error rendering 'slack.nextup.jira:slack-integration-plus'. Please contact your Jira administrators.