Uploaded image for project: 'C++ Driver'
  1. C++ Driver
  2. CXX-921

legacy driver fails to build on FreeBSD

    XMLWordPrintableJSON

Details

    Description

      Trying to compile mongo-cxx-driver on FreeBSD fails with error
      #error Must implement SecureRandom for platform

      The OpenBSD implementation for SecureRandom should work on FreeBSD as well (not checked, as I have no direct access to a FreeBSD installation at the moment).

      You can see a complete log of the failure here:
      https://buildd.debian.org/status/fetch.php?pkg=mongo-cxx-driver-legacy&arch=kfreebsd-amd64&ver=1.1.1-1&stamp=1464681161

      Attachments

        Issue Links

          Activity

            People

              rassi J Rassi
              giuliopaci Giulio Paci
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: