Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-16315

Replica set nodes should not threaten to veto nodes whose config version is higher than their own

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: 2.6.5, 2.8.0-rc1
    • Fix Version/s: 2.6.8, 2.8.0-rc2
    • Component/s: Replication
    • Labels:
      None
    • Backwards Compatibility:
      Minor Change
    • Operating System:
      ALL
    • Backport Completed:

      Description

      When a node receives a replSetFresh request from a node that reports a higher replica set config version than its own, it should not threaten to veto the election of the remote node. After all, it does not know if, under the logic of the new configuration, it will be appropriate to veto.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: