WiredTiger (mostly) uses the term "log archiving" to refer to the deletion of old log files. This is confusing to newbies, since "archive" has a different meaning from "remove". It is also non-standard usage. Oracle and IBM both describe log archiving as the copying/moving of log files to different storage media for disaster recovery, as does Gray and Reuter's book on Transaction Processing.
It would be simpler and less confusing to simply call log removal "log removal". There are three general areas this change would effect:
- Documentation. E.g., the description of Log-based incremental backup
- Internal code and comments. E.g., changing the name of log_archive_once() to log_remove_once().
- Configuration files and other APIs. Currently we use the configuration option log=(archive=false) to specify that log files should not be removed.
The final item, above, may be the stickiest. I don't know willing we are to change user/client-facing interfaces.